replace lots of manual install commands with INSTALL_* variables
[openwrt-10.03/.git] / package / ebtables / Makefile
index f4359a6675d56e8f9c7482104fa5003d7f5cca6d..41c1e0fcda62081ef220712e3cbecc1d32c7dfd3 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -6,32 +12,32 @@ PKG_NAME:=ebtables
 PKG_VERSION:=2.0.8-rc2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ebtables
 PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
 PKG_CAT:=zcat
 
-include $(TOPDIR)/package/rules.mk
+PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
 
 define Package/ebtables
-SECTION:=base
-CATEGORY:=Network
-TITLE:=Ethernet bridge firewall administration utility
-DESCRIPTION:=Ethernet Bridge Firewalling (ebtables)
-URL:=http://ebtables.sourceforge.net/
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Ethernet bridge firewall administration utility
+  URL:=http://ebtables.sourceforge.net/
 endef
 
 define Package/ebtables/install
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/ethertypes $(1)/etc/
-       install -d -m0755 $(1)/usr/lib/ebtables
-       install -m0755 $(PKG_BUILD_DIR)/lib*.so $(1)/usr/lib/
-       install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(1)/usr/lib/ebtables/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ebtables $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/ethertypes $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/lib/ebtables
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib*.so $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/extensions/*.so $(1)/usr/lib/ebtables/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ebtables $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ebtables-save $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ebtables-restore $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ebtables))