change cp to $(CP)
[openwrt-10.03/.git] / package / e2fsprogs / Makefile
index 1fcd3cbbb7316424eba3a6a93deed99116572617..b4393e2ebb330857f72bf01b44199a60c4b55837 100644 (file)
@@ -19,7 +19,7 @@ include $(TOPDIR)/package/rules.mk
 $(eval $(call PKG_template,E2FSPROGS,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); rm -rf config.#cache,status}; \
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
@@ -69,11 +69,11 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_E2FSPROGS):
        mkdir -p $(IDIR_E2FSPROGS)/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/e2fsck $(IDIR_E2FSPROGS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/mke2fs $(IDIR_E2FSPROGS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkfs.ext{2,3} $(IDIR_E2FSPROGS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/tune2fs $(IDIR_E2FSPROGS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/e2fsck $(IDIR_E2FSPROGS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/mke2fs $(IDIR_E2FSPROGS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/mkfs.ext{2,3} $(IDIR_E2FSPROGS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/tune2fs $(IDIR_E2FSPROGS)/sbin/
        mkdir -p $(IDIR_E2FSPROGS)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{blkid,com_err,e2p,ext2fs,uuid}.so.* $(IDIR_E2FSPROGS)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{blkid,com_err,e2p,ext2fs,uuid}.so.* $(IDIR_E2FSPROGS)/usr/lib/
        $(RSTRIP) $(IDIR_E2FSPROGS)
        $(IPKG_BUILD) $(IDIR_E2FSPROGS) $(PACKAGE_DIR)