[backfire] fix block-extroot on brcm-2.4 (#9454)
[openwrt-10.03/.git] / package / e2fsprogs / Makefile
index bf744147bb9b2792553a764c459d6ea2d7821ea5..21942ef0dd87ae9835c6279022f8e9f1063274c6 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Copyright (C) 2006-2008 OpenWrt.org
-#
+# Copyright 2010 Vertical Communications
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.40.11
-PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_VERSION:=1.41.11
+PKG_MD5SUM:=fb507a40c2706bc38306f150d069e345
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -156,8 +156,8 @@ define Package/e2fsprogs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/e2fsck.init $(1)/etc/init.d/e2fsck
-
+       $(INSTALL_DIR) $(1)/lib/functions/fsck
+       $(INSTALL_DATA) ./files/e2fsck.sh $(1)/lib/functions/fsck/
 endef
 
 define Package/libuuid/install