fix HAVE_ISC_READER related error
[openwrt-10.03/.git] / package / dnsmasq / Makefile
index 19c6d35627b4414fea5a7dd7511952533e7d9d1b..2208a06ce4244eb099c195cde208eeb63ac8b35f 100644 (file)
@@ -1,18 +1,24 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.27
+PKG_VERSION:=2.33
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
+PKG_MD5SUM:=45696461b6e6bc929273b1191ca50447
 PKG_CAT:=zcat
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/dnsmasq
 SECTION:=base
@@ -24,14 +30,25 @@ coupled DNS and DHCP service to a LAN.
 URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
+define Package/dnsmasq/conffiles
+/etc/dnsmasq.conf
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               all
+endef
+
 define Package/dnsmasq/install
-       install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
-       install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d/
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(IDIR_DNSMASQ)/usr/sbin/
-       install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc/dnsmasq.conf
-       install -m0755 ./files/dnsmasq.init $(IDIR_DNSMASQ)/etc/init.d/S50dnsmasq
-       $(RSTRIP) $(IDIR_DNSMASQ)
-       $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
+       install -m0755 -d $(1)/etc
+       install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       install -m0755 -d $(1)/etc/init.d
+       install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,dnsmasq))