valgrind: update to 3.12.0
[openwrt/.git] / package / devel / valgrind / patches / 200-musl_fix.patch
index 7bb20296d39f73fbb9d8610a5d8b4206928fd8a3..c6e6a6628f7516fee1cb0d571561c07a596a7dd7 100644 (file)
@@ -1,26 +1,26 @@
 --- a/coregrind/vg_preloaded.c
 +++ b/coregrind/vg_preloaded.c
-@@ -56,7 +56,7 @@
- void VG_NOTIFY_ON_LOAD(freeres)( void );
- void VG_NOTIFY_ON_LOAD(freeres)( void )
+@@ -57,7 +57,7 @@
+ void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run);
+ void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run)
  {
 -#  if !defined(__UCLIBC__) \
 +#  if !defined(__UCLIBC__) && defined(__GLIBC__) \
-    && !defined(VGPV_arm_linux_android) && !defined(VGPV_x86_linux_android) \
-    && !defined(VGPV_mips32_linux_android)
-    extern void __libc_freeres(void);
+       && !defined(VGPV_arm_linux_android) \
+       && !defined(VGPV_x86_linux_android) \
+       && !defined(VGPV_mips32_linux_android) \
 --- a/include/pub_tool_redir.h
 +++ b/include/pub_tool_redir.h
-@@ -241,7 +241,7 @@
+@@ -243,7 +243,7 @@
  /* --- Soname of the standard C library. --- */
  
- #if defined(VGO_linux)
+ #if defined(VGO_linux) || defined(VGO_solaris)
 -#  define  VG_Z_LIBC_SONAME  libcZdsoZa              // libc.so*
 +#  define  VG_Z_LIBC_SONAME  libcZdZa                // libc.*
  
  #elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
  #  define  VG_Z_LIBC_SONAME  libSystemZdZaZddylib    // libSystem.*.dylib
-@@ -273,7 +273,11 @@
+@@ -275,7 +275,11 @@
  /* --- Soname of the pthreads library. --- */
  
  #if defined(VGO_linux)
 +# endif
  #elif defined(VGO_darwin)
  #  define  VG_Z_LIBPTHREAD_SONAME  libSystemZdZaZddylib  // libSystem.*.dylib
- #else
+ #elif defined(VGO_solaris)
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1031,8 +1031,6 @@ case "${GLIBC_VERSION}" in
-      *)
+@@ -1047,8 +1047,6 @@ case "${GLIBC_VERSION}" in
+       ;;
+      2.0|2.1|*)
        AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
--      AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.19])
--      AC_MSG_ERROR([or Darwin or Bionic libc])
+-      AC_MSG_ERROR([Valgrind requires glibc version 2.2 or later,])
+-      AC_MSG_ERROR([Darwin libc, Bionic libc or Solaris libc])
        ;;
  esac