hostapd: add wpa_strict_rekey support
[openwrt/.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
index 84d1f60f2fe01140ab27a24d5aa5c84c7250dc8d..f07ac8ca24ba37dc634a01e5761d1ff61eb713d7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1293,13 +1293,13 @@ if test -z "$LD"; then
+@@ -1283,13 +1283,13 @@ if test -z "$LD"; then
    fi
  fi
  
 +  LDFLAGS="$LDFLAGS -static-libstdc++"
 +  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
    AC_LANG_PUSH(C++)
-   AC_LINK_IFELSE([
+   AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1625,7 +1625,7 @@ AC_ARG_WITH(stage1-ldflags,
-  # if supported.  But if the user explicitly specified the libraries to use,
+@@ -1629,7 +1629,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
-  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+  if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
+      -a "$have_static_libs" = yes; then
 -   stage1_ldflags="-static-libstdc++ -static-libgcc"
 +   stage1_ldflags="-static-libstdc++"
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1654,7 +1654,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1658,7 +1658,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -4998,14 +4998,14 @@ if test -z "$LD"; then
+@@ -5053,14 +5053,14 @@ if test -z "$LD"; then
    fi
  fi
  
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5788,7 +5788,7 @@ else
-  # if supported.  But if the user explicitly specified the libraries to use,
+@@ -5861,7 +5861,7 @@ else
   # trust that they are doing what they want.
-  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+  if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
+      -a "$have_static_libs" = yes; then
 -   stage1_ldflags="-static-libstdc++ -static-libgcc"
 +   stage1_ldflags="-static-libstdc++"
   fi
  fi
  
-@@ -5824,7 +5824,7 @@ else
+@@ -5897,7 +5897,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then