move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt-10.03/.git] / package / comgt / patches / 001-Makefile.patch
index 28ea2ecf27ff4d056561a624168a748b9af8c384..32b56b12b747e0170c33f5e7b80f68814e702a97 100644 (file)
@@ -1,32 +1,90 @@
---- gcom-0.3.x/Makefile        2006-01-04 17:05:28.000000000 +0200
-+++ gcom-0.3/Makefile  2006-02-26 13:02:07.000000000 +0200
-@@ -20,8 +20,6 @@
+Index: comgt.0.32/Makefile
+===================================================================
+--- comgt.0.32.orig/Makefile   2007-06-04 13:22:22.665409616 +0200
++++ comgt.0.32/Makefile        2007-06-04 13:22:22.730399736 +0200
+@@ -1,7 +1,6 @@
  #
- #     $Id$
+-#   Makefile - build and install the comgt package
++#   Makefile - build and install the gmon package
+ #   Copyright (C) 2005  Martin Gregorie
+-#   Copyright (C) 2006  Paul Hardwick
  #
+ #   This program is free software; you can redistribute it and/or modify
+ #   it under the terms of the GNU General Public License as published by
+@@ -17,63 +16,41 @@
+ #    along with this program; if not, write to the Free Software
+ #    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ #
+-#    martin@gregorie.org, paul@peck.org.uk
++#    martin@gregorie.org
+ #
+-#    $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
++#     $Id$
+ #
+-#
+-
 -LIB     = -L/usr/local/lib
 -INC     = -I/usr/local/include
  EXE   = /usr/local/bin
  MAN     = /usr/share/man/man1
- CPROG = gcom
-@@ -29,9 +27,6 @@
- BIN     = $(CPROG) $(SCRIPT)
- MANP  = gcom.1 sigmon.1
+-CPROG = comgt
+-SCRIPTPATH = /etc/comgt/
+-SCRIPTSRC = ./scripts/
+-BIN     = $(CPROG) 
+-MANP  = comgt.1 sigmon.1
+-
 -CFLAGS  = -c
 -LDFLAGS =
--
++CPROG = gcom
++SCRIPT  = sigmon
++BIN     = $(CPROG) $(SCRIPT)
++MANP  = gcom.1 sigmon.1
  all: $(BIN)
  
  install:
-@@ -53,8 +48,8 @@
++      mv ($BIN} {$BIN2}
+       chmod a-w $(BIN)
+       chmod u+rw $(BIN)
+       chmod a+x $(BIN)
+-      cp $(BIN) $(EXE)
++      cp $(BIN) $(EXE)/gcom
+       chmod a-wx $(MANP)
+       chmod u+rw $(MANP)
+       chmod a+r $(MANP)
+       cp $(MANP) $(MAN)
+-      -mkdir $(SCRIPTPATH)
+-      chmod a-w $(SCRIPTPATH)
+-      chmod u+rw $(SCRIPTPATH)
+-      chmod a+x $(SCRIPTPATH)
+-      cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
+-      chmod a-w $(SCRIPTPATH)*
+-      chmod u+rw $(SCRIPTPATH)*
+-      chmod a+x $(SCRIPTPATH)*
+-
+-
+-
+ uninstall:
+       cd $(EXE); rm $(BIN)
+       cd $(MAN); rm $(MANP)
+-      -rm -r $(SCRIPTPATH)
+ clean:
+-      -rm *.o 
+-      -rm $(CPROG) 
+-      -rm *~
+-      -rm $(SCRIPTSRC)*~
++      rm *.o $(CPROG)
  
  
- gcom: gcom.o
--      cc gcom.o $(LDFLAGS) -o gcom
+-comgt: comgt.o
+-      cc comgt.o $(LDFLAGS) -o comgt
++gcom: gcom.o
 +      $(CC) gcom.o $(LDFLAGS) -o gcom
  
- gcom.o: gcom.c gcom.h
--      cc gcom.c $(CFLAGS) 
-+      $(CC) -c $(CFLAGS) gcom.c
+-comgt.o: comgt.c comgt.h
+-      cc comgt.c $(CFLAGS) 
++gcom.o: comgt.c comgt.h
++      $(CC) -c $(CFLAGS) comgt.c -o gcom.o