standardize Makefile, change section and category to utils, remove dup description
[openwrt-10.03/.git] / package / busybox / patches / 300-netmsg.patch
index 22ca172c5c0cfae4d0a80362395199fa1204cb78..428e321390d3a0279ad2a317038c9a8d1fe3995e 100644 (file)
@@ -1,20 +1,23 @@
-diff -urN busybox.old/include/applets.h busybox.dev/include/applets.h
---- busybox.old/include/applets.h      2006-01-11 01:32:47.302791000 +0100
-+++ busybox.dev/include/applets.h      2006-01-11 01:33:18.744756250 +0100
-@@ -475,6 +475,9 @@
- #ifdef CONFIG_NC
-       APPLET(nc, nc_main, _BB_DIR_USR_BIN, _BB_SUID_NEVER)
- #endif
-+#ifdef CONFIG_NETMSG
-+      APPLET_NOUSAGE("netmsg", netmsg_main, _BB_DIR_BIN, _BB_SUID_ALWAYS)
-+#endif
- #ifdef CONFIG_NETSTAT
-       APPLET(netstat, netstat_main, _BB_DIR_BIN, _BB_SUID_NEVER)
- #endif
-diff -urN busybox.old/networking/Config.in busybox.dev/networking/Config.in
---- busybox.old/networking/Config.in   2005-11-01 00:55:15.000000000 +0100
-+++ busybox.dev/networking/Config.in   2006-01-11 01:33:18.744756250 +0100
-@@ -435,6 +435,12 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+diff -ruN busybox-1.2.0-old/include/applets.h busybox-1.2.0-new/include/applets.h
+--- busybox-1.2.0-old/include/applets.h        2006-07-31 10:47:56.000000000 +0200
++++ busybox-1.2.0-new/include/applets.h        2006-07-31 11:21:00.000000000 +0200
+@@ -200,6 +200,7 @@
+ USE_MV(APPLET(mv, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NAMEIF(APPLET(nameif, _BB_DIR_SBIN, _BB_SUID_NEVER))
+ USE_NC(APPLET(nc, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
++USE_NETMSG(APPLET_NOUSAGE(netmsg, netmsg, _BB_DIR_BIN, _BB_SUID_ALWAYS))
+ USE_NETSTAT(APPLET(netstat, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NICE(APPLET(nice, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NOHUP(APPLET(nohup, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
+diff -ruN busybox-1.2.0-old/networking/Config.in busybox-1.2.0-new/networking/Config.in
+--- busybox-1.2.0-old/networking/Config.in     2006-07-01 00:42:02.000000000 +0200
++++ busybox-1.2.0-new/networking/Config.in     2006-07-31 11:18:01.000000000 +0200
+@@ -445,6 +445,12 @@
        help
          A simple Unix utility which reads and writes data across network
          connections.
@@ -27,10 +30,10 @@ diff -urN busybox.old/networking/Config.in busybox.dev/networking/Config.in
  
  config CONFIG_NC_GAPING_SECURITY_HOLE
        bool "gaping security hole"
-diff -urN busybox.old/networking/Makefile.in busybox.dev/networking/Makefile.in
---- busybox.old/networking/Makefile.in 2005-11-01 00:55:15.000000000 +0100
-+++ busybox.dev/networking/Makefile.in 2006-01-11 01:34:02.939518250 +0100
-@@ -28,6 +28,7 @@
+diff -ruN busybox-1.2.0-old/networking/Makefile.in busybox-1.2.0-new/networking/Makefile.in
+--- busybox-1.2.0-old/networking/Makefile.in   2006-07-01 00:42:02.000000000 +0200
++++ busybox-1.2.0-new/networking/Makefile.in   2006-07-31 11:18:01.000000000 +0200
+@@ -30,6 +30,7 @@
  NETWORKING-$(CONFIG_IPTUNNEL)     += iptunnel.o
  NETWORKING-$(CONFIG_NAMEIF)       += nameif.o
  NETWORKING-$(CONFIG_NC)           += nc.o
@@ -38,10 +41,15 @@ diff -urN busybox.old/networking/Makefile.in busybox.dev/networking/Makefile.in
  NETWORKING-$(CONFIG_NETSTAT)      += netstat.o
  NETWORKING-$(CONFIG_NSLOOKUP)     += nslookup.o
  NETWORKING-$(CONFIG_PING)         += ping.o
-diff -urN busybox.old/networking/netmsg.c busybox.dev/networking/netmsg.c
---- busybox.old/networking/netmsg.c    1970-01-01 01:00:00.000000000 +0100
-+++ busybox.dev/networking/netmsg.c    2006-01-11 01:33:18.748756500 +0100
-@@ -0,0 +1,58 @@
+diff -ruN busybox-1.2.0-old/networking/netmsg.c busybox-1.2.0-new/networking/netmsg.c
+--- busybox-1.2.0-old/networking/netmsg.c      1970-01-01 01:00:00.000000000 +0100
++++ busybox-1.2.0-new/networking/netmsg.c      2006-07-31 11:18:01.000000000 +0200
+@@ -0,0 +1,63 @@
++/*
++ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
++ *
++ * This is free software, licensed under the GNU General Public License v2.
++ */
 +#include <sys/types.h>
 +#include <sys/socket.h>
 +#include <netinet/in.h>