sync with buildroot2 from uclibc, add devices, may be used to build other kernel...
[openwrt-10.03/.git] / package / busybox / busybox.mk
index ae9abf1332f32e7c45d5866cc3b3b7b7c6892aa0..e19aa7bc4f416468050921b6076a1e7e94d96c82 100644 (file)
@@ -26,7 +26,7 @@ busybox-source: $(DL_DIR)/$(BUSYBOX_SOURCE) $(BUSYBOX_CONFIG)
 $(BUSYBOX_DIR)/.unpacked: $(DL_DIR)/$(BUSYBOX_SOURCE)
        $(BUSYBOX_UNZIP) $(DL_DIR)/$(BUSYBOX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        # Allow busybox patches.
-       toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox-\*.patch
+       toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox/patches
        touch $(BUSYBOX_DIR)/.unpacked
 
 $(BUSYBOX_DIR)/.configured: $(BUSYBOX_DIR)/.unpacked $(BUSYBOX_CONFIG)
@@ -60,3 +60,12 @@ busybox-clean:
 
 busybox-dirclean:
        rm -rf $(BUSYBOX_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_BUSYBOX)),y)
+TARGETS+=busybox
+endif