ath9k: due to popular request, allow ad-hoc+ap again, now that the beacon code can...
[openwrt-10.03/.git] / package / br2684ctl / patches / 100-debian.patch
index bfcd4ec6a38b062533ecd6a48158bf62bd015960..8a8b3b743c9c1a9a12386873b602e7f576fa42b7 100644 (file)
@@ -1,5 +1,5 @@
---- br2684ctl-20040226.orig/br2684ctl.c
-+++ br2684ctl-20040226/br2684ctl.c
+--- a/br2684ctl.c
++++ b/br2684ctl.c
 @@ -3,6 +3,8 @@
  #include <unistd.h>
  #include <errno.h>
@@ -22,7 +22,7 @@
  
  
  int lastsock, lastitf;
-@@ -39,10 +41,16 @@
+@@ -39,10 +41,16 @@ void fatal(const char *str, int i)
  
  void exitFunc(void)
  {
@@ -40,7 +40,7 @@
  int create_pidfile(int num)
  {
    FILE *pidfile = NULL;
-@@ -80,7 +88,7 @@
+@@ -80,7 +88,7 @@ int create_br(char *nstr)
        err=ioctl (lastsock, ATM_NEWBACKENDIF, &ni);
    
        if (err == 0)
@@ -49,7 +49,7 @@
        else
        syslog(LOG_INFO, "Interface \"%s\" could not be created, reason: %s\n",
               ni.ifname,
-@@ -112,7 +120,7 @@
+@@ -112,7 +120,7 @@ int assign_vcc(char *astr, int encap, in
      addr.sap_addr.vpi = 0;
      addr.sap_addr.vci = vci;
  #endif
@@ -58,7 +58,7 @@
           addr.sap_addr.vpi,
           addr.sap_addr.vci,
           encap?"VC mux":"LLC");
-@@ -261,11 +269,13 @@
+@@ -261,11 +269,13 @@ int main (int argc, char **argv)
    }
    
    create_pidfile(itfnum);
@@ -73,8 +73,8 @@
    return 0;
  }
  
---- br2684ctl-20040226.orig/Makefile
-+++ br2684ctl-20040226/Makefile
+--- /dev/null
++++ b/Makefile
 @@ -0,0 +1,13 @@
 +OPTS := -O2
 +CFLAGS := -Wall -g