base-files: remove an old network tunable tweak which is messing up network stack...
[openwrt-10.03/.git] / package / br2684ctl / Makefile
index cd668e2f7e4d66f73dd4f9a2560e1d245778cbd3..4af040b4e13cafd7528c606ba970a9e760855b27 100644 (file)
@@ -4,9 +4,9 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6582 2007-03-16 20:21:39Z nbd $
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=br2684ctl
 PKG_VERSION:=20040226
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
 PKG_MD5SUM:=6eb4d8cd174e24a7c078eb4f594f5b69
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
 PKG_BUILD_DEPENDS:=linux-atm
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,6 +29,7 @@ define Package/$(PKG_NAME)
   URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
 endef
 
+TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
 MAKE_FLAGS += CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)"
 
 define Package/$(PKG_NAME)/install