uboot-*: update license info in uboot packages
[openwrt/.git] / package / boot / uboot-omap / Makefile
index 45d32bd3c3a446328db84bc6cc2d83a34f0bb32e..6e836d047a6fdd88d819556b67c7e672213b0822 100644 (file)
@@ -19,6 +19,9 @@ PKG_SOURCE_URL:= \
 PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
 PKG_TARGETS:=bin
 
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
 include $(INCLUDE_DIR)/package.mk
 
 define uboot/Default
@@ -71,7 +74,7 @@ endif
 
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(UBOOT_CONFIG)_config
+               USE_PRIVATE_LIBGCC=yes $(UBOOT_CONFIG)_config
 endef
 
 define Build/Compile