Add ar7-atm fixes by DerAgo, also fix compilation (the use of dumb inlining in protot...
[openwrt-10.03/.git] / package / ar7-atm / patches / 130-powercutback.patch
diff --git a/package/ar7-atm/patches/130-powercutback.patch b/package/ar7-atm/patches/130-powercutback.patch
new file mode 100644 (file)
index 0000000..0dc495d
--- /dev/null
@@ -0,0 +1,44 @@
+--- atm.old/tn7dsl.c   2006-10-26 16:48:44.000000000 +0200
++++ atm.dev/tn7dsl.c   2007-06-22 23:36:27.000000000 +0200
+@@ -2864,6 +2811,14 @@
+     dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
+   }
++  // set powercutback
++  ptr = NULL;
++  ptr = prom_getenv("powercutback");
++  if(ptr)
++  {
++    dslhal_advcfg_onOffPcb(pIhw, os_atoi(ptr));
++  }
++
+   // trellis
+   ptr = NULL;
+   ptr = prom_getenv("trellis");
+--- atm.old/Makefile   2007-06-24 18:46:25.000000000 +0200
++++ atm.dev/Makefile   2007-06-24 18:46:31.000000000 +0200
+@@ -4,6 +4,7 @@
+ CONFIG_SANGAM_ATM=m
+ #EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
+-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
++#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
++EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
+ obj-$(CONFIG_SANGAM_ATM) := tiatm.o
+-tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
++tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
+--- atm.old/dsl_hal_advcfg.c   2007-06-24 19:22:42.000000000 +0200
++++ atm.dev/dsl_hal_advcfg.c   2007-06-24 19:21:42.000000000 +0200
+@@ -36,9 +36,9 @@
+ *    05Jul05     0.00.09            CPH    CQ9775: Change dslhal_advcfg_configDsTones input parameters & support for ADSL2+
+ *    24Jul05     0.00.10            CPH    Fixed comments in dslhal_advcfg_configDsTones function header
+ *******************************************************************************/
+-#include <dev_host_interface.h>
+-#include <dsl_hal_register.h>
+-#include <dsl_hal_support.h>
++#include "dev_host_interface.h"
++#include "dsl_hal_register.h"
++#include "dsl_hal_support.h"
+ /*****************************************************************************/
+ /* ACT API functions -- To be moved into their own independent module --RamP */