[ar7] migrate acx to netdev_ops, required for later kernels
[openwrt-10.03/.git] / package / acx-mac80211 / patches / 001-build_module.diff
index 3c1fcda33e46513d8bcc0ce4d54b73dfe400ddd3..ee4a8d4c894194fdd649b509db45fcb1d246164a 100644 (file)
@@ -1,11 +1,11 @@
---- acx-mac80211-20070610/Makefile     2007-06-10 20:23:27.000000000 +0200
-+++ acx-mac80211-20070610//Makefile    2007-07-23 17:00:34.000000000 +0200
-@@ -4,7 +4,7 @@
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
- #acx-mac80211-objs := wlan.o conv.o ioctl.o common.o $(acx-mac80211-obj-y)
--acx-mac80211-objs :=  common.o $(acx-mac80211-obj-y)
-+acx-mac80211-objs :=  common.o $(acx-mac80211-obj-m)
- # Use this if you have proper Kconfig integration:
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),)
      obj-$(CONFIG_ACX_MAC80211) += acx-mac80211.o
+       acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
+       acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
+-      acx-mac80211-objs := common.o $(acx-mac80211-obj-y)
++      acx-mac80211-objs := common.o $(acx-mac80211-obj-m)
+ else
+ # Otherwise we were called directly from the command line: the the kernel build
+ # system must be explicitly invoked.