reorder netfilter patches, update layer7 kernel to latest version, should improve...
[openwrt-10.03/.git] / include / verbose.mk
index 36002aee990b029c8eb6907e421ef4a4b47a5853..b4242f212acc512c4d66533932bf86838f374eab 100644 (file)
@@ -18,7 +18,7 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
-ifneq ($(shell tty -s <&3 || echo x),x)
+ifeq ($(IS_TTY),1)
   _Y:="\\33[33m"# yellow
   _N:="\\33[m"#        normal
 endif
@@ -36,7 +36,7 @@ ifneq ($(KBUILD_VERBOSE),99)
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)