trigger a kernel module rebuild when the kernel config changes
[openwrt-10.03/.git] / include / verbose.mk
index 525fbf1c157178e6d4e2c4c39fa0a93222e31bba..99747ed3fd4f46ad6ef347e0260a2f798c4ae374 100644 (file)
@@ -18,20 +18,25 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
+endif
+
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
        }
   else
     export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)