reorder nas command line parameters (required for bridge operation)
[openwrt-10.03/.git] / include / verbose.mk
index 77a877efe3c4071f55d4bafebc8c18e776aceaad..6d7c7ef6c16fd01f9b9a3413c494dced13114704 100644 (file)
@@ -1,14 +1,14 @@
 # OpenWrt.org 2006
 # $Id:$
 
-ifeq ($(DUMP),)
-  ifndef KBUILD_VERBOSE
-    KBUILD_VERBOSE=0
-    ifeq ("$(origin V)", "command line")
-      KBUILD_VERBOSE=$(V)
-    endif
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE=0
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE=$(V)
   endif
+endif
 
+ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
@@ -18,6 +18,10 @@ ifeq ($(DUMP),)
        }
   else
     export QUIET:=1
+    NO_TRACE_MAKE:=$(MAKE) V=99
+    ifeq ($(KBUILD_VERBOSE),0)
+      MAKE:=&>/dev/null $(MAKE)
+    endif
     MAKE:=3>&1 4>&2 $(MAKE)
   endif