[adm5120] fix switch driver, force all packets from all the ports are low priority
[openwrt-10.03/.git] / include / verbose.mk
index 31e0cea1b3107626d776fef4b782f7c4c7c16ec1..6b2d6d044ba2722e1d83eefdeb89105f818ca425 100644 (file)
@@ -1,17 +1,31 @@
-# OpenWrt.org 2006
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id:$
 
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
+
 ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=1
-  else
-    KBUILD_VERBOSE=99
-  endif
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
+endif
+
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
 endif
 
+define MESSAGE
+       echo -e "$(_Y)$(1)$(_N)" >&3
+endef
 
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
@@ -19,14 +33,14 @@ ifneq ($(KBUILD_VERBOSE),99)
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+               $(call MESSAGE, "make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)"); \
        }
   else
     export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=3>&1 4>&2 $(MAKE)
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)