fix everything I broke with the previous patches
[openwrt-10.03/.git] / include / verbose.mk
index 98dfd5632b6292ded3459283c7a344f0fa149e6a..525fbf1c157178e6d4e2c4c39fa0a93222e31bba 100644 (file)
@@ -6,11 +6,16 @@
 #
 # $Id:$
 
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
+
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -23,11 +28,10 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
-    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=3>&1 4>&2 $(MAKE)
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)