fix everything I broke with the previous patches
[openwrt-10.03/.git] / include / verbose.mk
index 58a20a217841e8d5ceb8dc10741a8a10717b222c..525fbf1c157178e6d4e2c4c39fa0a93222e31bba 100644 (file)
@@ -6,10 +6,16 @@
 #
 # $Id:$
 
-NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=$(V)
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -29,6 +35,4 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
-else
-   NO_TRACE_MAKE:=$(MAKE)
 endif