fix accidental double slash in prefixed quilt patchsets
[openwrt-10.03/.git] / include / verbose.mk
index 525fbf1c157178e6d4e2c4c39fa0a93222e31bba..4abdf8d661fa6f137111992348999d2e6e0a3d2f 100644 (file)
@@ -8,7 +8,9 @@
 
 ifeq ($(NO_TRACE_MAKE),)
 NO_TRACE_MAKE := $(MAKE) V=99
+SUBMAKE := $(MAKE)
 export NO_TRACE_MAKE
+export SUBMAKE
 endif
 
 ifndef KBUILD_VERBOSE
@@ -18,20 +20,31 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
+endif
+
+define MESSAGE
+       /bin/echo -e "$(_Y)$(1)$(_N)" >&3
+endef
+
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
-    $(MAKECMDGOALS): trace
-    trace: FORCE
-       @[ -f "$(MAKECMDGOALS)" ] || { \
-               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
-       }
+    ifneq ($(CURDIR),$(TOPDIR))
+      _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
+    else
+      _DIR:=
+    endif
+    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+               $(call MESSAGE, "make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)"); \
+    ))
   else
-    export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
+    export QUIET:=1
+    MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)