add a simple prerequisite check
[openwrt-10.03/.git] / include / verbose.mk
index c998b3d1c9944740a996bf3b1bc5ebee269564f1..16a75c08c9744ff741d46f397576d697c4a9d11f 100644 (file)
@@ -6,9 +6,11 @@
 #
 # $Id:$
 
+NO_TRACE_MAKE:=$(MAKE) V=99
+
 ifndef KBUILD_VERBOSE
   KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
+  ifdef V
     KBUILD_VERBOSE=$(V)
   endif
 endif
@@ -23,7 +25,6 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
-    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
@@ -31,4 +32,6 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+   NO_TRACE_MAKE:=$(MAKE)
 endif