nuke mdev and replace it with hotplug2 :)
[openwrt-10.03/.git] / include / unpack.mk
index 94124e9ec6c3fcdb3f680b146b141d176dd69bd5..7813e3b3d35683d18b4a7ad08e8a1410b448b055 100644 (file)
@@ -8,7 +8,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
     # use existing PKG_CAT
     PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
     ifeq ($(PKG_CAT),unzip)
-      PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+      PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
     endif
     # replace zcat with $(ZCAT), because some system have it as gzcat
     ifeq ($(PKG_CAT),zcat)
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
   else
     # try to autodetect file type
   endif
+  ifneq ($(strip $(CRLF_WORKAROUND)),)
+    PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+  endif
 endif