add 2 helper macros to deal with libtool madness
[openwrt-10.03/.git] / include / target.mk
index 7f0501e5957a7948b79dbde566effd15dc51b40a..b0a178e306d409319d0797fa11fe68c7edcc0a80 100644 (file)
@@ -1,12 +1,21 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.target.mk
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
 
-$(TMP_DIR)/.target.mk:
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+-include $(TMP_DIR)/.target.mk
+
+ifeq ($(IB),1)
+$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
+       $(CP) $< $@
+endif