add 2 helper macros to deal with libtool madness
[openwrt-10.03/.git] / include / target.mk
index 6a136a1bee4dbd16d7eee3a4b84f45b7c6075dd2..b0a178e306d409319d0797fa11fe68c7edcc0a80 100644 (file)
@@ -1,32 +1,21 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define AddProfile
-  $(eval $(call Profile/Default))
-  $(eval $(call Profile/$(1)))
-  ifneq ($(ID),)
-    PROFILE:=$(ID)
-       $(ID)_NAME:=$(NAME)
-       $(ID)_PACKAGES:=$(PACKAGES)
-    ifneq ($(KCONFIG),)
-      PROFILE_LIST += \
-               echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
-    endif
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
   endif
 endef
 
-
-include $(TMP_DIR)/.target.mk
+-include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@
-else
-$(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
 endif