mac80211: add rate control rewrite and enhance the performance of the minstrel algori...
[openwrt-10.03/.git] / include / target.mk
index 357bb1f30dfe58e268609142cca12878f2938688..5b7bf9829e8cdebb76e45431fce1073645ad9ba5 100644 (file)
@@ -15,6 +15,8 @@ DEVICE_TYPE?=router
 DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper bridge firewall
+# LuCI
+DEFAULT_PACKAGES.router+=luci-admin-full luci-i18n-english luci-app-firewall luci-sgi-cgi
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
@@ -133,7 +135,7 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
-    ifneq ($(CONFIG_USB),)
+    ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
       FEATURES += usb
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)