mac80211: add rate control rewrite and enhance the performance of the minstrel algori...
[openwrt-10.03/.git] / include / target.mk
index 34d2935fe8333a65e18166a67e3cd4163d38ccb1..5b7bf9829e8cdebb76e45431fce1073645ad9ba5 100644 (file)
@@ -12,9 +12,11 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper bridge firewall
+# LuCI
+DEFAULT_PACKAGES.router+=luci-admin-full luci-i18n-english luci-app-firewall luci-sgi-cgi
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
@@ -133,7 +135,7 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
-    ifneq ($(CONFIG_USB),)
+    ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
       FEATURES += usb
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)