fix partition align
[openwrt-10.03/.git] / include / package.mk
index 82298b02498677b08c81a001b24f01f414e8d803..cf8756ea63ecb58811947b07509099222913702c 100644 (file)
@@ -6,7 +6,7 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
       ifeq ($(CONFIG_AUTOREBUILD),y)
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
@@ -201,14 +201,15 @@ define BuildPackage
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
+  ifeq ($(PKG_CAT),unzip)
+    UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+  else
+    UNPACK=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+  endif
   define Build/Prepare/Default
-       @if [ "$(PKG_CAT)" = "unzip" ]; then \
-               unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE) ; \
-       else \
-               $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) - ; \
-       fi                                                
+       $(UNPACK)
        @if [ -d ./patches ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
+               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef
 endif