Remove installation of incompatible getopt.h, closes #753, #754, #755
[openwrt-10.03/.git] / include / package.mk
index 385a84653741e1f24995bab3823f1980b63655fe..9a947f358248338773337f374e0d996ba8a45b8e 100644 (file)
@@ -15,13 +15,22 @@ include $(INCLUDE_DIR)/prereq.mk
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifeq ($(CONFIG_AUTOREBUILD),y)
+      _INFO:=
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+       _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+        _INFO+=$(subst $(TOPDIR)/,,$(IPKG_$(1)))
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
+
+      ifneq ($(MAKECMDGOALS),prereq)
+        ifneq ($$(_INFO),)
+          $$(info Rebuilding $$(_INFO))
+        endif
+      endif
     endif
   endif
 
@@ -122,6 +131,10 @@ define BuildPackage
 
     ifneq ($(CONFIG_PACKAGE_$(1)),)
       compile-targets: $$(IPKG_$(1))
+    else
+      compile-targets: $(1)-disabled
+      $(1)-disabled:
+       @echo "WARNING: skipping $(1) -- package not selected"
     endif
   endif
 
@@ -224,7 +237,7 @@ define BuildPackage
   clean: $(1)-clean
 
   $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
-       -rm $(PKG_BUILD_DIR)/.version-$(1)_*
+       -@rm $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
@@ -250,7 +263,7 @@ endef
 
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
-       [ -x configure ] && \
+       if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -274,7 +287,7 @@ define Build/Configure/Default
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                $(1); \
-               true; \
+       fi; \
        )
 endef