Prevent SSH keys from being chmoded to 644 (#664), looks like those are the only...
[openwrt-10.03/.git] / include / package.mk
index 706b38d12a20a1b43369f8b03b15535d8c87845d..87e76be2b53248470485c0c317310ce490111038 100644 (file)
@@ -273,7 +273,7 @@ endef
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
-       @if [ -d ./patches ]; then \
+       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef