fix prereqs
[openwrt-10.03/.git] / include / package.mk
index ce07640eeda5d47573a34d4034669a41accbb044..757c8396aeb1279ef6c4f5890cb1bc2c7b469951 100644 (file)
@@ -83,6 +83,7 @@ define Package/Default
   DEFAULT:=
   MENU:=
   SUBMENU:=
+  SUBMENUDEP:=
   TITLE:=
   DESCRIPTION:=
 endef
@@ -142,6 +143,10 @@ define BuildPackage
   ifneq ($(SUBMENU),)
     DUMPINFO += \
        echo "Submenu: $(SUBMENU)";
+    ifneq ($(SUBMENUDEP),)
+      DUMPINFO += \
+         echo "Submenu-Depends: $(SUBMENUDEP)";
+    endif
   endif
 
   ifneq ($(DEFAULT),)
@@ -294,7 +299,7 @@ else
        mkdir -p $@
                
   ifneq ($(strip $(PKG_SOURCE)),)
-    source: $(DL_DIR)/$(PKG_SOURCE)
+    download: $(DL_DIR)/$(PKG_SOURCE)
 
     $(DL_DIR)/$(PKG_SOURCE):
                mkdir -p $(DL_DIR)
@@ -303,7 +308,7 @@ else
     $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
   endif
 
-  source:
+  download:
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured