fix pesky kmod-* ipkg install bug
[openwrt-10.03/.git] / include / package.mk
index 4e67e732468d5983253b4b5dc2e3f6d1a1b431ce..69606464ae497cb11eae7d14466f7a571f3a1977 100644 (file)
@@ -208,11 +208,11 @@ define BuildPackage
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
        ( \
-               DEPENDS=; \
+               DEPENDS='$(EXTRA_DEPENDS)'; \
                for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
-               echo "Depends: $(EXTRA_DEPENDS) $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
        )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control