remove old control directory
[openwrt-10.03/.git] / include / package.mk
index 2d4e703f3b6a9e25dcb1669496790564c66e57e5..5636b0b6a1d8c226a1977359ac784b7b35257029 100644 (file)
@@ -290,7 +290,7 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR)/$(3); \
+       (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -346,7 +346,7 @@ else
   $(PACKAGE_DIR):
        mkdir -p $@
                
-  ifneq ($(strip $(PKG_SOURCE)),)
+  ifneq ($(strip $(PKG_SOURCE_URL)),)
     download: $(DL_DIR)/$(PKG_SOURCE)
 
     $(DL_DIR)/$(PKG_SOURCE):