Add new warning to help track down pesky compile issues
[openwrt-10.03/.git] / include / package.mk
index 79c29bccf67fd6851949c2a3a74db7a6d2214cac..311ec35a9c1ebf3b36a1c6fb4c27ab5d370e2a47 100644 (file)
@@ -15,13 +15,22 @@ include $(INCLUDE_DIR)/prereq.mk
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifeq ($(CONFIG_AUTOREBUILD),y)
+      _INFO:=
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+       _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+        _INFO+=$(subst $(TOPDIR)/,,$(IPKG_$(1)))
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
+
+      ifneq ($(MAKECMDGOALS),prereq)
+        ifneq ($$(_INFO),)
+          $$(info Rebuilding $$(_INFO))
+        endif
+      endif
     endif
   endif
 
@@ -122,6 +131,10 @@ define BuildPackage
 
     ifneq ($(CONFIG_PACKAGE_$(1)),)
       compile-targets: $$(IPKG_$(1))
+    else
+      compile-targets: $(1)-disabled
+      $(1)-disabled:
+       @echo "WARNING: skipping $(1) -- package not selected"
     endif
   endif
 
@@ -251,11 +264,11 @@ endef
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
        [ -x configure ] && \
-               $(2) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               $(2) \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -283,7 +296,7 @@ define Build/Configure
 endef
 
 define Build/Compile/Default
-       PATH=$(TARGET_PATH) $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CROSS="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \