the default_subtargets template was a bad idea, since different makefiles require...
[openwrt-10.03/.git] / include / package-ipkg.mk
index b71fce42a8fccb2601b5dcab3c0789f45f20dcef..ac6912844b029300318035a6523fef094ef1dd4a 100644 (file)
@@ -17,20 +17,12 @@ ifeq ($(DUMP),)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
     ifdef Package/$(1)/install
-      ifneq ($(CONFIG_PACKAGE_$(1)),)
+      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
         compile: $$(IPKG_$(1))
 
         ifeq ($(CONFIG_PACKAGE_$(1)),y)
           install: $$(INFO_$(1))
         endif
-
-        ifneq ($(MAKECMDGOALS),prereq)
-          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-            $(PKG_BUILD_DIR)/.built: package-rebuild
-            $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
-          endif
-        endif
-
       else
         compile: $(1)-disabled
         $(1)-disabled:
@@ -71,9 +63,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false