check if the Package/$(NAME) template is defined before packaging or installing ipkg...
[openwrt-10.03/.git] / include / modules-2.6.mk
index ec9f5da44f48466ff89d20153746bf6e5c39485d..c98e4ea8a492b970e27d9b35445d8877d89182ad 100644 (file)
@@ -1,5 +1,11 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 NF_2_6:=1
-include $(TOPDIR)/include/netfilter.mk
+include $(INCLUDE_DIR)/netfilter.mk
 
 # Networking
 
@@ -112,11 +118,6 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
 
 # Block devices
 
-$(eval $(call KMOD_template,IDE,ide,\
-       $(MODULES_DIR)/kernel/drivers/ide/*.ko \
-       $(MODULES_DIR)/kernel/drivers/ide/*/*.ko \
-,CONFIG_IDE))
-
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.ko \
 ,CONFIG_BLK_DEV_LOOP,,20,loop))