move the cryptoapi kmod to package/kernel
[openwrt-10.03/.git] / include / modules-2.4.mk
index 71864ad8eb795383488a92bdaf6cea69e0e781c2..93a897373444dd30bf94e0a7da7daa2a360e1c40 100644 (file)
@@ -1,4 +1,10 @@
-include $(TOPDIR)/include/netfilter.mk
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(INCLUDE_DIR)/netfilter.mk
 
 # Networking
 
@@ -107,11 +113,6 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
 
 # Block devices
 
-$(eval $(call KMOD_template,IDE,ide,\
-       $(MODULES_DIR)/kernel/drivers/ide/*.o \
-       $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
-
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \
 ,CONFIG_BLK_DEV_LOOP,,20,loop))
@@ -121,16 +122,6 @@ $(eval $(call KMOD_template,NBD,nbd,\
 ,CONFIG_BLK_DEV_NBD,,20,nbd))
 
 
-# Crypto
-
-ifneq ($(wildcard $(MODULES_DIR)/kernel/crypto/*.o),)
-CONFIG_CRYPTO:=m
-endif
-$(eval $(call KMOD_template,CRYPTO,crypto,\
-       $(MODULES_DIR)/kernel/crypto/*.o \
-,CONFIG_CRYPTO))
-
-
 # Filesystems
 
 $(eval $(call KMOD_template,FS_CIFS,fs-cifs,\