fix find_config() in the network scripts
[openwrt-10.03/.git] / include / kernel.mk
index 7b959eaeaacf43935b304c0d93dac599c70aef37..c788bf1c49092d4ce05b4a95ebad7a878a639396 100644 (file)
@@ -38,6 +38,14 @@ else
        -e 's/armeb/arm/' \
   )
 
+  KERNELNAME=
+  ifneq (,$(findstring x86,$(BOARD)))
+    KERNELNAME="bzImage"
+  endif
+  ifneq (,$(findstring ppc,$(BOARD)))
+    KERNELNAME="uImage"
+  endif
+
   ifneq (,$(findstring uml,$(BOARD)))
     LINUX_KARCH:=um
     KERNEL_CC:=$(HOSTCC)