fix find_config() in the network scripts
[openwrt-10.03/.git] / include / kernel.mk
index 4b5fe72f0097ec11591644bfe46c44397215ff6e..c788bf1c49092d4ce05b4a95ebad7a878a639396 100644 (file)
@@ -38,10 +38,13 @@ else
        -e 's/armeb/arm/' \
   )
 
-  KERNELNAME=""
+  KERNELNAME=
   ifneq (,$(findstring x86,$(BOARD)))
     KERNELNAME="bzImage"
   endif
+  ifneq (,$(findstring ppc,$(BOARD)))
+    KERNELNAME="uImage"
+  endif
 
   ifneq (,$(findstring uml,$(BOARD)))
     LINUX_KARCH:=um