disable wgt634u images for linux 2.4 (only works with 2.6)
[openwrt-10.03/.git] / include / kernel-build.mk
index 706764db5819aea93a2b198f4d9d66e9a22c89b1..942a91516bdb2b8b6a43662d2b9cdb95e1c95b5d 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 -include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
@@ -99,7 +105,9 @@ $(TOPDIR)/.kernel.mk:
        echo "LINUX_RELEASE:=$(LINUX_RELEASE)" >> $@
 
 pkg-install: FORCE
-       @{ [ "$(INSTALL_TARGETS)" != "" ] && $(IPKG) install $(INSTALL_TARGETS) || true; }
+       @for pkg in $(INSTALL_TARGETS); do \
+               $(IPKG) install $$pkg || echo; \
+       done
 
 source: $(DL_DIR)/$(LINUX_SOURCE)
 prepare: $(LINUX_DIR)/.configured
@@ -127,3 +135,4 @@ clean: FORCE
        rm -f $(STAMP_DIR)/.linux-compile
        rm -rf $(KERNEL_BUILD_DIR)
        rm -f $(TARGETS)
+