add workaround for kernel module install
[openwrt-10.03/.git] / include / kernel-build.mk
index 3a455a812ecdb95fc4c427b0bd0f72dde7d55066..55a74701c7bb9b4bfc489a721636894043b54cba 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 -include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
@@ -99,7 +105,9 @@ $(TOPDIR)/.kernel.mk:
        echo "LINUX_RELEASE:=$(LINUX_RELEASE)" >> $@
 
 pkg-install: FORCE
-       @{ [ "$(INSTALL_TARGETS)" != "" ] && $(IPKG) install $(INSTALL_TARGETS) || true; }
+       @for pkg in $(INSTALL_TARGETS); do \
+               $(IPKG) install $$pkg || echo; \
+       done
 
 source: $(DL_DIR)/$(LINUX_SOURCE)
 prepare: $(LINUX_DIR)/.configured