change 'source' to 'download'
[openwrt-10.03/.git] / include / image.mk
index f30f0997eee1fe3ca7c1810385d26fc2d93e7b36..95accd6e1d1f886cc1535cf4f3352a691e2e97b9 100644 (file)
@@ -1,5 +1,9 @@
-include $(TOPDIR)/rules.mk
-
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -17,6 +21,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
+               # add End-of-Filesystem markers
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
        
                $(call Image/Build,jffs2-64k)
                $(call Image/Build,jffs2-128k)