fix find_config() in the network scripts
[openwrt-10.03/.git] / include / image.mk
index 95accd6e1d1f886cc1535cf4f3352a691e2e97b9..903c27ba6333d52376cbcd5de20f2094c5e2429b 100644 (file)
@@ -44,8 +44,18 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
+  
+  
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
+  define Image/mkfs/ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(call Image/Build,ext2)
+  endef
+endif
+
+
 define Image/mkfs/prepare/default
        find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
@@ -69,6 +79,7 @@ install:
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/ext2)
        
 clean:
        $(call Build/Clean)
@@ -78,7 +89,7 @@ compile-targets:
 install-targets:
 clean-targets:
 
-source:
+download:
 prepare:
 compile: compile-targets
 install: compile install-targets