fix issues if kernel config is changed after the compile has started
[openwrt-10.03/.git] / include / image.mk
index 95accd6e1d1f886cc1535cf4f3352a691e2e97b9..660734c9f7a9ddad9644a2e4c0ab5c64df2552f2 100644 (file)
@@ -44,6 +44,14 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
+  
+  ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
+    define Image/mkfs/ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(call Image/Build,ext2)
+    endef
+  endif
+  
 endif
 
 define Image/mkfs/prepare/default
@@ -69,6 +77,7 @@ install:
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/ext2)
        
 clean:
        $(call Build/Clean)
@@ -78,7 +87,7 @@ compile-targets:
 install-targets:
 clean-targets:
 
-source:
+download:
 prepare:
 compile: compile-targets
 install: compile install-targets