fix issues if kernel config is changed after the compile has started
[openwrt-10.03/.git] / include / image.mk
index 54f0e8b6bc96dcf9c4fd05a02eb35060ae1e59b4..660734c9f7a9ddad9644a2e4c0ab5c64df2552f2 100644 (file)
@@ -47,7 +47,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   
   ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
     define Image/mkfs/ext2
-               genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
     endef
   endif
@@ -87,7 +87,7 @@ compile-targets:
 install-targets:
 clean-targets:
 
-source:
+download:
 prepare:
 compile: compile-targets
 install: compile install-targets