add block2mtd by default in x86-2.6
[openwrt-10.03/.git] / include / image.mk
index f30f0997eee1fe3ca7c1810385d26fc2d93e7b36..06516791805b082711a321d483977c675d976ad7 100644 (file)
@@ -1,5 +1,9 @@
-include $(TOPDIR)/rules.mk
-
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -17,6 +21,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
+               # add End-of-Filesystem markers
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
        
                $(call Image/Build,jffs2-64k)
                $(call Image/Build,jffs2-128k)
@@ -33,11 +41,21 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               tar -zcf $(BIN_DIR)/openwrt-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
+               tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
+  
+  
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
+  define Image/mkfs/ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(call Image/Build,ext2)
+  endef
+endif
+
+
 define Image/mkfs/prepare/default
        find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
@@ -61,6 +79,7 @@ install:
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/ext2)
        
 clean:
        $(call Build/Clean)
@@ -70,7 +89,7 @@ compile-targets:
 install-targets:
 clean-targets:
 
-source:
+download:
 prepare:
 compile: compile-targets
 install: compile install-targets