fix a rebuild bug related to quilt
[openwrt-10.03/.git] / include / host-build.mk
index b5c2a2203d00673115469a608c0e39c6e34325e2..f4b6b449e1ef7a67552f4f50b1a94f9a2750f1ab 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/depends.mk
 STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s)
 STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
 STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+override MAKEFLAGS=
 
 include $(INCLUDE_DIR)/quilt.mk
 
@@ -30,6 +31,7 @@ endef
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
        [ -x configure ] && \
+               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/$(3)/ && \
                $(2) \
                CPPFLAGS="-I$(STAGING_DIR)/host/include" \
                LDFLAGS="-L$(STAGING_DIR)/host/lib" \
@@ -78,11 +80,11 @@ ifneq ($(strip $(PKG_SOURCE)),)
   $(STAMP_PREPARED): $(DL_DIR)/$(PKG_SOURCE)
 endif
 
-ifneq ($(CONFIG_AUTOREBUILD),)
+ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostBuild/Autoclean
     $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
-    $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+    $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
   endef
 endif
 
@@ -103,7 +105,6 @@ define HostBuild
 
   $(STAMP_BUILT): $(STAMP_CONFIGURED)
        $(call Build/Compile)
-       @$(NO_TRACE_MAKE) $(PKG_BUILD_DIR)/.dep_files
        touch $$@
 
   $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed: $(STAMP_BUILT)