next round of cleanup, convert target/ - make -j works now ;)
[openwrt-10.03/.git] / include / host-build.mk
index b5c2a2203d00673115469a608c0e39c6e34325e2..d83446558eccbfcfac8c61a79a2921f5f564e25c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/depends.mk
 STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s)
 STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
 STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+override MAKEFLAGS=
 
 include $(INCLUDE_DIR)/quilt.mk
 
@@ -30,6 +31,7 @@ endef
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
        [ -x configure ] && \
+               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/$(3)/ && \
                $(2) \
                CPPFLAGS="-I$(STAGING_DIR)/host/include" \
                LDFLAGS="-L$(STAGING_DIR)/host/lib" \