add workaround for freebsd
[openwrt-10.03/.git] / include / host-build.mk
index 43c83142dfe6effab403f7d30024d79d8db7263a..5670b6f17db78992e10a8a5e95fedeeafb9c29ed 100644 (file)
@@ -4,6 +4,26 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
+include $(TOPDIR)/.host.mk
+
+$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host-build.mk
+       echo "HOST_OS:=`uname`" > $@
+       echo "HOST_ARCH:=` \
+               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+                       -e 's/sparc.*/sparc/' \
+                       -e 's/arm.*/arm/' \
+                       -e 's/m68k.*/m68k/' \
+                       -e 's/ppc/powerpc/' \
+                       -e 's/v850.*/v850/' \
+                       -e 's/sh[234]/sh/' \
+                       -e 's/mips-.*/mips/' \
+                       -e 's/mipsel-.*/mipsel/' \
+                       -e 's/cris.*/cris/' \
+                       -e 's/i[3-9]86/i386/'`" >> $@
+       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+
+
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
     UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
@@ -64,7 +84,7 @@ endef
 
                
 ifneq ($(strip $(PKG_SOURCE)),)
-  source: $(DL_DIR)/$(PKG_SOURCE)
+  download: $(DL_DIR)/$(PKG_SOURCE)
 
   $(DL_DIR)/$(PKG_SOURCE):
        mkdir -p $(DL_DIR)
@@ -101,7 +121,7 @@ define HostBuild
        $(call Build/Uninstall)
        rm -f $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
 
-  source:
+  download:
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured