fix build issues that happen when the staging dir is cleared and the build directorie...
[openwrt-10.03/.git] / include / download.mk
index 1f227e221c8dafc624d0b69e56e628f1a0371637..23f2996ed14004436cf345c12e2be54798160890 100644 (file)
@@ -23,8 +23,8 @@ $(strip \
 endef
 
 # code for creating tarballs from svn/git checkouts - useful for mirror support
-dl_pack/bz2=tar cfj $(1) $(2)
-dl_pack/gz=tar cfz $(1) $(2)
+dl_pack/bz2=$(TAR) cfj $(1) $(2)
+dl_pack/gz=$(TAR) cfz $(1) $(2)
 dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
 define dl_pack
        $(if $(dl_pack/$(call ext,$(1))),$(dl_pack/$(call ext,$(1))),$(dl_pack/unknown))
@@ -39,14 +39,12 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
-       ( $(1) ) \
-       $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+       @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
 endef
 
 define DownloadMethod/svn
        $(call wrap_mirror, \
-               echo "Checking out files from svn repository..."; \
+               echo "Checking out files from the svn repository..."; \
                mkdir -p $(TMP_DIR)/dl && \
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
@@ -59,8 +57,24 @@ define DownloadMethod/svn
        )
 endef
 
+define DownloadMethod/git
+       $(call wrap_mirror, \
+               echo "Checking out files from the git repository..."; \
+               mkdir -p $(TMP_DIR)/dl && \
+               cd $(TMP_DIR)/dl && \
+               rm -rf $(SUBDIR) && \
+               [ \! -d $(SUBDIR) ] && \
+               git-clone $(URL) $(SUBDIR) && \
+               (cd $(SUBDIR) && git-checkout $(VERSION)) && \
+               echo "Packing checkout..." && \
+               rm -rf $(SUBDIR)/.git && \
+               $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+               mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+       )
+endef
+
 Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
 
 define Download/Defaults
   URL:=